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Welcome to Corte5 

Corte is a software to optimize cutting of sheets and bars capable of finding true optimum solutions that will minimize 
material usage for either consumption or cost. 

By using Corte you will be able to: 

 Design and document optimum cutting plans with a little effort and time. 

 Reduce material scraps drastically. 

 Calculate exact orders for your suppliers quickly 

 Reduce production costs significantly. 
 

Technical requirements 

Corte can run on any PC with Windows 95 or later operating system and a minimum hardware configuration. However, 
since the program uses both  RAM memory and processor time widely during calculations, its benefits will be considerably 
improved as long as these resources are increased.  

We recommend the following hardware configuration: 

 1 GHz  processor or superior (minimum of 360 MHz). 

 512 MB of RAM (minimum of 64 MB). 

 Printer with graphics capabilities. 
 

Getting and registering the final copy 

You can ask for the Corte FINAL copy and your User License at our Web site www.corteoptimo.com. There you’ll be 
informed about prices and payment. 

We will need your Product ID in order to assign you a license number. To get this ID, select About Corte from Help menu 
and look at the bottom of the window displayed. From here, you also can press Register and right-click in “Product ID” box 
to copy the number. 

Once you’ve got your FINAL copy and User License, do the following: 

1. Uninstall the DEMO copy. 

2. Install the FINAL copy and run it.  

The program will start in evaluation mode. 

3. In the About Corte window, select Register. 

4. Introduce the requested data and press OK. 

On successful registration, both your user name and license number will appear at the bottom of the About Corte window 
and all restrictions to the evaluation copy will be disabled.   

  
Additional help 

We will be pleased of attending any doubt or suggestion you email to support@corteoptimo.com. 

http://www.corteoptimo.com/
mailto:support@corteoptimo.com
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Corte5 User’s Manual 

Presentation 

Corte is a software for automatic elaboration of cutting plans of materials in sheets or bars shape which is singular as for 
being specially designed to offer its users a real chance to accede true-optimum solutions of the given tasks. It is supported 
by a powerful mathematical model allowing this fundamental goal can be fulfilled in most cases and when it cannot a very 
close-to solution will be guaranteed. 

The program can be really applied in cutting  of different types of material such as metal, glass, paper, wood and others, in 
dissimilar practical situations. That can be done by defining technological options that will adjust cutting patterns to match, 
as much as possible, both material and cutting-tool characteristics. 

1. Benefits 

The main benefits of Corte are: 

 A simple and very flexible interface. 

 Calculation of cutting patterns in a fully automatic way. 

 Optimum solutions with a very high probability. 

 Alternative optimization in order to minimize material usage for either consumption or cost. 

 Background calculations. 

 Technological options in order to satisfy both cutting and tooling requirements. 

 Customized units with wide support for either Metric or English system. 

 Customized labels and other output texts. 

 Unlimited quantity for the number of part and material formats. 

 Assignment and calculation of edge-coverings. 

 Options to weigh up optimization quality and speedy. 

 Manual edition and adjustment of patterns. 

 Printed reports with all necessary information to document and execute cutting plans. 

 Import and Export of Excel sheets with program inputs and outputs. 

 Export of AutoCAD® 2000 DXF drawings. 

2. Limitations 

You cannot use complex-shaped parts with polygonal or curve contours, unless you define rectangular hulls for them but 
knowing full well that material losses will arise though could be avoided  if part locations were fitted together. 

The generated cutting variants will always be of guillotine type, with material edge-to-edge cuts, which is more restrictive 
than other technologies such as rip cutting. Here, however, possible losses would be widely compensated with the high 
optimization achieved and so it’s almost for sure that Corte will have the same effectiveness in practice. 

3. Extensions 

By setting technological options properly and imposing certain rules to data definition, you even will be able to optimize 
some technologies that are different practically but similar conceptually to that of the program. Two examples are profiles 
cutting-at-angle and multiple part punching in CNC presses.  

4. About writing and reading this manual 

This manual have been written with a dual aim of users can get basic knowledge to start using program quickly and also 
extend in advanced concepts to take advantage of all of its potentialities.  

All chapters have a structure divided in sections where topics of interest are explained. The last section in each chapter is 
always dedicated to describe actions that can be realized in relation to previously exposed concepts. In this way, options 
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from interface are going to be introduced according to exposition requirements, even standing in the way some being self-
explained. 

In a spirit of Corte can reach the best optimization possible in reasonable time even at hard cases (as when optimizing 
for a big number of parts), there exists several options allowing straightforward access to some calculation internals. That’s 
why we couldn’t avoid some chapters of a slight mathematical orientation to go into their meanings but whose reading you 
can omit till felling more comfortable.  As you may suppose, such critical options will assume all default values justified by 
practical experience. We are referring in particular to chapters “Optimization, Solutions, Results” and “Calculation Options”. 

The chapters “Cutting Patterns” and “Editing patterns manually” can also be put alter if your intention is (as ours) to leave 
Corte doing all hard work. We just insist here that you can create or modify cutting patterns manually. Before doing that, 
you should go back and read them.  

We specially recommend reading of chapters “Launches” and “Cutting Technology” exposing both the basis. Then, users 
urged on practicing without theorizing too much, can directly go into the How-tos and begin test. 

5. Actions 

 To see what’s new in Corte5 in relation to older versions: 

Read file “readme.txt” supplied with installation. 
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The Corte window 

Shows from top to bottom the following items: 

 Menu bar 

Leads users through all options in the program by functional categories. 

 Tools palette 

Contains several tool bars showing icons for the most used options . 

 Documents area 

Is where launch windows are located usually in maximized state. Corte  is an MDI (Multiple Document Interface) 
application which means you can work in several launches at the same time.   

 Status bar 

Contains three panels showing from left to right: the full name of the active launch, the  index of the current item in 
view and the Corte’s logo. First panel also shows texts describing menu options and inspector properties when 
cursor moves over. 

1. The launch window 

Consists of two sizeable panels, one for inspectors on the left and one for views on the right. The views are classified in 
data sheets (Parts, Materials and Strips) and output sheets (Results, Patterns and Report). 

The data sheets shows tables with records (rows) for data objects in the corresponding categories. The columns are fields or 
properties identifying those objects or being essential for calculation.  

The Results and Patterns sheets shows, respectively, numerical descriptions and graphics of the cutting patterns generated 
automatically during launch optimization. 

The inspectors, in general, reproduce and complement the current object selected in views (to which they associate with) by 
adding more specialized properties and others to express calculation results. In particular, the Launch Inspector summarize 
configuration and results of the whole cutting task. 

The combined usage of views and inspectors offers great flexibility for both data input and results reading at all levels. 

2. Actions 

 To change visualization state of tool bars: 

Select “Tool bars” from View menu or right-click in an empty zone of the palette to spread a context menu.   

 To see a short description for icons: 

Put cursor over and keep it still for a moment. 

 To change position of a tool bar: 

Drag from its separator on the left. 

 To organize launch Windows in documents area: 

Select options from Window menu.  

 To activate a launch: 

Click in its window or select it at end of Window menu. 

 To adjust horizontal width of inspectors: 

Drag vertical separator on the right of inspectors panel. 

 To change visualization state of inspectors: 

Select “Inspectors” from View menu. 

 To activate and bring to front a launch sheet: 

a) Click in its tab at top border of sheets panel. 

b) Select the corresponding option from View menu. 
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 To easily access options related to the active sheet: 

Right-click on the sheet to spread a context menu. 
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Launches 

A launch is a manager object of all information and actions necessary to prepare, optimize and realize a cutting task. From 
user’s point of view, launches constitutes the program working documents which are saved permanently as launch files (LAN 
extension).  

1. Structure 

The figure below summarizes launch structure (categories exposed straightforward in the interface are in bold): 
 

 

1.1 Configuration categories 

 Units 

Defines the measurement unit to express part-material dimensions and the consumption unit to express areas and 
material totals in either area or longitude. 

 Technology 

Defines options to set cutting technology.  

 Calculation 

Defines calculation options according to optimization objective. 

 Output 

Allows to customize texts and graphics in outputs. 

1.2 Cutting categories 

 Parts 

Final products to obtain as a result of cutting process. Parts must be defined with an associated quantity indicating 
solicitude or order. 

 Materials 

Stock materials to cut and consume. Materials can optionally be defined with an associated quantity indicating 
existence or availability.  

 Strips 

To cover part edges. 

 Patterns 

Describe how to cut material. 
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2. About working with launches 

Launches defines unique categories for both parts and materials by assuming (implicitly although not necessarily) that all 
introduced formats can be freely combined during optimization. That’s why  a launch should be associated with a cutting 
task specific to a technological type of material which can be characterized, in first place, by its bar-or-sheet shape and, in 
second place, by other properties like thickness and texture.  

A cutting plan for a complex product could require usage of different materials, technologies or any other practical criteria  
implying a none-unique formats categorization and thereby the existence of different technological groups for cutting. In 
such cases, you should define launches for each of these groups and save all of them in your hard disk (our 
recommendation) under the same folder identifying the whole cutting plan. That will make further management easier. 

2.1 Optimization groups 

Nevertheless what pointed above, with a little more effort, you can even manually simulate  and separately optimize several 
groups of formats in a single launch provided that such groups be technologically “compatible” which means, in our case, 
that they have the same Material Shape and Cut Width. These groups could express different material types, manufacturing 
priorities or any other constrain in cutting practical realization. 

See Optimizing groups of formats separately. 

3. Launch files and templates 

Launch files are in a text format similar to that of Windows configuration files and save all the information related to a 
cutting task without defining links to any other external data source. These two characteristics confer them the advantages 
of implementation simplicity and data autonomy that will facilitate information exchanging between applications and working 
stations or groups.  

You can save time when introducing often repeated data by using launch templates (PLA extension). New launches are 
always created starting from templates which can be the default ones for bars and sheets cutting (files defaultbars.pla and 
defaultsheets.pla in the installation folder) or other ones customized by users. To create a launch template, you should 
configure a launch first and then save it as a template. 

4. Actions 

 To create a launch new:  

Select “New” from File menu, chose a initial configuration and press OK. 

 To open an existing launch or template: 

Select  “Open” from File menu, chose the file type at the bottom of the window displayed and press OK. 

 To save all pending changes in the current launch: 

Select “Save” from File menu. 

 To save under a different name or extension: 

Select “Save as” from File menu. 

⇒ You can use this option to create duplicates of files. 

 To customize default folders for launches and templates: 

Select “Options” from Tools menu and go into Folders category.  

⇒ Templates saved in default folder will be automatically showed for selection when creating new launches. 

 To customize launch configuration: 

a) Select “Options” from Tools menu and go into Launch category.  

b) Select “Units”, “Cutting Technology” or “Optimization” from Prepare menu. 

c) Modify properties directly in Launch Inspector. 

 To define parts, materials and edge-covering strips: 

Edit records in the corresponding data sheets of the launch window. 
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Cutting Technology 

The cutting technology is a set of options and parameters conditioning cutting patterns geometry in order to fulfill both 
tooling and material requirements.  

1. Guillotine cutting 

The first technological restriction implicitly assumed by the calculation engine is the extraction of rectangular parts by using  
the so-called guillotine cutting, that is, with material edge-to-edge cuts always oriented at a right angle from the border 
being cut. Note this constrain does not condition cutting machine necessarily but only patterns topology. The rip-cutting 
tools, for example, can always cut guillotine variants.  

2. Options and parameters 

 Cutting type 

Defines both parts shape and material cutable dimensions. Use sheets for panels (rectangles) cutting and  bars for 
longitudes cutting. When activated bars cutting, Width dimension is ignored for all purposes and optimization is realized 
just by combining part lengths into materials lengths. 

 Reusable offcut 

Allows to detect reusable offcuts and define their minimum dimensions which will be applied whatever these pieces of 
materials are orientated. The reusable offcut is calculated and documented in program outputs.   

 Cut width 

Width of the strip of material smoothed out by the cutting tool. Geometrically, it defines a distance or separation 
between parts in the cutting patterns. 
 

 

 Minimum offcut 

Minimum length for the offcut could be left at the direction perpendicular to the cut. Any cut generating an offcut 
smaller than this longitude will  not be considered. 
 

 

 Maximum cut 

Maximum length the cutting tool can reach (considered infinite when reduced to 0). For example, in plateshears cutting 
it corresponds to the length of the blade. 
 

 

⇒ You can use this parameter to force direction of first cut. For example, when a material is horizontally oriented (Length 
is greater than Width), the first cut is guaranteed to be vertical if Maximum Cut is defined greater than Width but lesser 
than Length. 

 Hold length 
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Minimum length of a safety (also called dead) zone to hold the material before cutting it. 
 

 

 Cutting levels 

A cutting level is defined as the execution of cuts parallel to one rectangle dimension. Each time cut direction changes, 
the number of levels increments by 1. Restricting cutting levels reduces complexity of variants generated by the 
calculation engine. 

 

 

The number of levels restriction will be applied for intermediate semi-products only and not for final semi-products 
which are always assumed of level 0, that is, this parameter restricts the number of leves until reaching  parts or 
offcuts (the actual levels in a pattern could be one or two units greater than the specified one if cuts necessary to 
extract parts were included). 

 Parts per pattern 

Maximum amount of distinct parts (part types) that can be included in a cutting pattern (considered infinite when 
reduced to 0). 

 

 

⇒ When using this parameter you may consider the rounded-up solution instead of the exact one since completing 
variants generally leave a lot of offcut. We also recommend to disable calculation option “Avoid a degenerated 
solution…” not to limit a priori  any chance for combining parts (Seee Optimization, Solutions, Results). 

 Rotate parts 

Indicates whether parts can be rotated 90 degrees in cutting patterns. When active, chances for optimizing are 
significantly increased.  

 

 

 Material margins 

Reduce effective material area by defining not-to-cut strips at its borders. 
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The value of this option is a list containing strip widths for (in this order) left, right, bottom and top margins. 

Rotation and margins defined as part of cutting technology would affect all formats in the corresponding launch category 
(parts or materials). Furthermore, these two options can also be itemized for each of those objects. This duality allows to set 
a posteriori  a configuration fulfilled by not all but most formats.  

3. Scope 

Cutting technology includes options of hard application having a global and permanent scope in the launch, that is, they 
affect all the patterns no matter the moment they were created. Hard options are critical for drawing patterns and hence 
modifying them would imply a necessity to clean the solution. In particular, we’re referring to Cutting Type and Cut Width  
options (also Material Margins when applied at launch level although its scope is not permanent as explained before). 

The rest of the options are of relaxed application since they can be modified a posteriori at any time. They take place just at 
the moment of generating or editing a pattern to remain implicitly within its topology. 

4. Actions 

 To modify cutting technology: 

a) Select “Cutting Technology” from Prepare menu. 

b) Select “Options” from Tool menu and go into Technology category. 
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Cutting patterns 

A cutting pattern describes how to realize a cuts sequence for a material.  

1. Pattern topology 

As pattern topology (here sometimes called geometry in an informal way) we understand not only geometric properties of 
cuts such as longitude, direction and distance, but also order of realization and dependency relations among them. 

With the aim of fulfilling guillotine cutting restriction and also facilitating both correct interpretation and editing actions, 
patterns are showed at two stages of realization. First, a material is separated into cut semi-products by using either vertical 
or horizontal cuts until reaching part semi-products (which always repeat the same part type) or offcuts. Second, parts are 
extracted from their corresponding semi-products.  

Cut semi-products are considered intermediate and parts and offcuts finals in the process of realizing a cutting pattern. 

The figure below shows a tipical example of a cutting pattern. The blue lines are cuts of intermediate semi-products and red 
dashed lines are cuts of parts.  

 

2. Cuts hierarchy 

The two above mentioned stages in pattern topology implicitly define a cuts hierarchy which can be characterized by: 

a) There exits a root node identified with the original material. 

b) Every intermediate semi-product has two child nodes as a result of the given cut. 

c) Final semi-products has no children and constitute the end of the branchs in the hierarchy. 

The cuts hierarchy, besides being an alternative to select semi-products for edition, helps to understand practical realization 
of cutting by showing clearly the correct order of all cuts given and semi-products generated in a pattern.   

See Editing patterns manually. 

3. Parts offcut 

Part semi-products might have inner offcuts, at both vertical and horizontal directions, that should fulfill cutting technology 
requirements, that is, their longitudes in the corresponding directions should be greater than Minimum Offcut and if 
extended in the perpendicular directions would not be reusable (else would appear as separated semi-products). This is 
internally complemented with the additional restriction, for the case of Reusable Offcut was not enabled, that their areas be 
smaller than the occupied by parts. 
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Part offcuts are not cut explicitly for the reduced dimensions they generally have and also for being sometimes at both 
directions in a single semi-product. Here, cutting could be started either vertically or horizontally, leaving this choice to user. 

4. Exception for holding  

The proposed cuts sequence will always guarantee a correct pattern practical realization unless a holding zone is defined in 
cutting technology. In such a case, it could be necessary to subordinate some final semi-products cuts in order to guarantee 
existence of such a zone. In the example above, after C1, strips of part P2 can be horizontally cut from bottom to top, 
subordinating C6 and guaranteeing a minimum holding equal to P4 width.  

Note that final semi-product cuts can always be replaced with part strips cuts oriented in the same direction. 

5. Actions 

 To  adjust the pattern view: 

a) Drag a rectangle to zoom in the view. 

b) Select “Pattern view” from View menu. 

 To see the cuts hierarchy: 

Activate Cuts Inspector. 

 To select a semi-product: 

a) From Patterns Sheet, click inside the pattern showed. 

b) Select a node in the Cuts Inspector. 

c) Drag a rectangle as if doing zoom and press SHIFT before release. The first semi-product fully contained in the window 
defined this way will be selected. 

⇒ When there is no semi-product selection, the pattern root node will be assumed as the current one for editing actions. 

 To navigate through all semi-products: 

Use arrow keys from the selected semi-product. 

 To remove semi-product selection: 

a) Click outside the pattern.  

b) Select  “Deselect” from Adjust menu. 

 To navigate through all the patterns: 

a) From Patterns Sheet, use the navigator in tools palette. 

b) Use arrow keys with no semi-product selection. 
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Optimization, Solutions, Results 

Typical of cutting problems is the huge number of different solutions that might exist for a single task, even when a few 
parts are to be cut. Then, optimization consists in the process of searching for a solution satisfying best certain optimization 
criterion. In Corte you can alternatively chose to minimize either consumption or cost of material available. 

1. Solutions 

A solution of the launch is a collection of cutting patterns where each pattern is associated with a value of multiplicity or 
repetition indicating how many material units should be consumed. Since the same part can appear in different patterns, the 
whole order will not be fulfilled until all patterns be realized, each as many times as indicated by its repetition.  

The figure below describes a very fortunate cutting task and its optimum solution with a 100% of material yield. 

 

1.1 Theoretic solution 

The Corte‘s calculation engine implements an exact mathematical model to calculate a continuous optimum solution for 
the given cutting task. Such a solution, that we call Theoretic Solution (first calculation phase), will not be realizable in 
practice, at least directly, because it assigns decimal, in general non-integer, repetitions to patterns.  

However, the theoretic solution plays a fundamental roll since, besides assuring an inferior bound for the optimization 
objective (and that taking into account all cutting restrictions), constitutes a starting point to obtain a solution realizable in 
practice with a very high probability of being optimum too.  

In searching for such a solution, a strategy of Rounding and Completing (second and third calculation phases) is applied as 
explained in the following 

1.2 Rounding modes 

 Up 

Theoretic multiplicities of patterns are rounded to integer values so that each part order be fulfilled in equality or 
excess. Such values are not chosen trivially but “the best ones” according to a rounding criterion. 

 Down 

In a similar but symmetric way, the parts order is fulfilled in equality or defect. 

 Exact 

By starting from down-rounding and applying a completing criterion, some additional cutting variants are generated 
until satisfying exactly each part order. These variants constitutes the completing patterns which can be easily 
identified for having a null (zero) theoretic multiplicity. 

 Theoretic 
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This mode is defined just to allow users accessing the theoretic solution. 

1.3 Integer solutions 

Thus, according to the above rounding modes, you can actually accede up to 4 solutions for the cutting task, all of them 
defined over the same patterns set: the theoretic solution and the exact, up and down integer solutions. We call the last two 
as the rounded ones. Once chosen a particular solution, patterns with zero repetition (nullified) are implicitly disabled for 
program outputs.  

By default Corte will assume the exact integer solution. However, the up integer solution could also be of a special 
interest as should fulfill parts order with lesser quantity in the number of pattern types and greater yield than the exact one, 
not so consumption which should be a bit greater. With the up-solution most offcut becomes parts. 

1.3.1 Optimality 

The rounded solutions are both optimum but just for the parts real achieved which, in general, does not coincide with user 
order. 

You can assure the exact solution is optimum if: 

a) The parts order was fulfilled. 

b) For each material used, the integer total (IT) of repetition is not greater than theoretic total (TT) rounded up 
(IT < TT+1). 

Finally, we summarizes in the following table the 

1. 4 Advantages and disadvantages of the different solutions 

 

CHARACTERISTIC THEORETIC EXACT UP DOWN 

Fulfills order Yes Yes Yes No 

Realizable in practice No Yes Yes Yes 

Number of patterns Lesser Greater Lesser Lesser 

Optimum Yes Quite probable Yes Yes 

Material consumption Lesser Lesser Greater Lesser 

Material yield Greater Lesser Greater Greater 

2. Results 

The totals for material consumption and cost, reports and output tables conforming program results are always calculated 
from the contribution in materials, parts and edge-covering strips made by the active patterns in the chosen current 
solution. These results can be obtained either at launch or individual cutting object level. It is even possible to restrict active 
patterns temporarily by defining a patterns filter in the solution. By doing so, partial results would be obtained just for those 
patterns satisfying certain conditions imposed by user.  

3. Actions 

 To optimize the launch: 

Select “Calculate patterns…” from Solution menu. 

 To optimize cost instead of consumption:  

Assign costs per unit of area to all materials and change optimization criterion to “Minimize cost”. 

 To see an estimate of the  minimum material consumption: 

Select “Ideal consumption…” from Tools menu. 

 To see the numerical description and graphics of the patterns in the current solution: 

Activate results and patterns sheets from launch window. 
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 To read optimization results at both launch and cutting object level: 

Read properties under Results category from the corresponding inspectors. You can also read the totals at the end of 
the Results Sheet. 

 To temporarily restrict active patterns in the current solution: 

Select “Filter of patterns” from Solution menu. 

 To activate the different solutions: 

Select “Rounding” from Solution menu. 

 To modify the optimization, rounding and completing criteria: 

Select “Options” from Tools menu and go into Calculation category. 

 To activate the patterns nullified: 

Select “Options” from Tools menu and go into Output category. 
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Calculation options 

This chapter deals with advanced concepts related to manual configuration of calculation and causes tending to delay 
optimization process of the launch. 

1. Optimization versus Performance 

In general, options in this category allow to establish a practical agreement between quality and speedy of the optimization.  

Further on we refer sometimes to a generic material by using expressions such as “a percentage of material”. Such a 
material is artificially built by taking the greatest dimensions Length and Width among all introduced formats. 

1.1 Restricting possible cuts 

The calculation of the theoretic solution (TS) decisively affects both achieved quality and total time of the whole 
optimization. This phase consist in an iterative process of generating cutting variants that continuously improve the current 
solution. When it cannot be possible any more, the theoretic optimum of the cutting task will have been reached. 

A critical parameter when generating cutting variants is the quantity of possible (points of) cuts analyzed along both material 
dimensions. If it reach a very large value, the whole process could be slowed significantly. On the other hand,  if it is 
restricted too much, some well-optimizing variants could be lost. The possible cuts are calculated as a function of part 
dimensions (and not orders which are irrelevant). Therefore, it is to expect a notable increment of its quantity in launches 
with a great number of different parts formats or parts of very short dimensions.   

The options restricting possible cuts in TS are: 

 Optimization level 

Allows to define a range of up to 3 optimization levels that will be successively applied during the phase by limiting 
implicitly possible cuts with some geometric criteria without extending parts dimensions. The higher level, the greater 
quality but the lesser performance. At level 3, optimization is best and there is no implicit restriction for possible cuts. 

 Current process acceleration 

Limits implicitly possible cuts by extending parts dimensions up to a 50% of material in correspondence with values 
within a range from 0 to 10 taken by this option. Unlike optimization level, which is applied globally during the phase,  
acceleration is automatically reset each time a new process begins and continues decreasing until value 0 where there 
is no restriction for possible cuts by this concept. The acceleration can even be manually modified during calculation if 
not defined before. The use of this option will not guarantee a decrease of the total calculation time, rather it allows to 
reach a solution with a high material yield faster. Although it should not affect final quality of optimization theoretically, 
we have verified in practice occasional loss of some variants that would have facilitated realization of subsequent 
phases affecting slightly final results. 

 Restrict possible cuts 

Limits explicitly possible cuts by extending a priori parts dimensions to certain percentage of material length or width. 
The impact of this option is permanent during the whole phase and should certainly provoke a decrease of the total 
calculation time. 

1.2 Avoiding a degenerated theoretic solution 

When a part with reduced dimensions in relation to material is ordered at little quantity, it generally occurs that area 
necessary to extract it does not cover at least a small percentage of a material unit. Since variants in theoretic solution are 
all generated without restricting parts repetitions, a high probability exists that a pattern distributing such a part will do it in 
quantities much greater than its order, thereby pattern multiplicity will tend to zero for compensating that difference. Such 
patterns conform what we call a degenerated theoretic solution because if they are not nullified yet, would surely be at 
Rounding phase which makes their generation useless. 

The option “Avoid a degenerated…by excluding parts…” is defined to discard a priori the above situation. Together with it, a 
percentage of material area that parts should cover to not be excluded from theoretic solution can also be specified. By “part 
covered area” is understood ordered quantity times part area. 

1. 3 Rounding and Completing bounds 

These two parameters limit internally the number of variants analyzed in each of these phases. 

The table below shows some recommended values for different processor speeds (CPU). 

CPU 0.5 Hz 1 Hz 2 Hz 3 Hz 
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Rounding bound 500 1000 2000 3000 

Completing bound 500 500 1000 1500 

1.4 Forcing calculation manually 

It could happen that calculation engine goes into a long cycle of bringing near theoretical optimum (generally when yield 
reaches a very high value) in which yield does not increment or does at a very low rate after generated a significant number 
of variants. In such situations, or at any time, you can manually force calculation to abort current process and go into next 
one immediately. Note that forcing calculation does not necessarily imply a phase change. Nevertheless what pointed out 
here and provided you are plenty of time, we recommend to leave calculation finalizes by its own without any interruption 
that could affect final result of optimization.   

2. Calculation phases 

You can decide which calculation phases to apply even though it is not absolutely recommended to omit any of them in 
order to reach the best optimization possible; only for those specific cases making evident their uselessness or when trying 
to improve the “optimum” achieved by modifying rounding or completing criteria. We exclude from that the option “Keep 
current patterns”, which is not a phase in fact, essential to optimize groups of formats separately and maintain patterns 
created manually in solution.  

The following are particular situations where it is convenient to omit certain phases of calculation. Note that deactivating TS 
doesn’t mean deleting it but omitting its calculation to take the existing one. To delete TS physically (and also the rest of 
solutions) you should delete all patterns. 

 Completing is enough 

When it’s evident a full-degenerated ST since a very little consumption is expected (1 or 2 material units), you’d better 
realize calculation with completing phase only.  

In general, optimizing this way, although could diminish total time, leads to poor results. Try the examples supplied in 
installation and you’ll be pleasantly disappointed when comparing optimizations realized with and without ST 
calculation.  

 The probable integer optimum is exceeded. 

Try to change first rounding and then completing criterion and repeat calculation using TS calculated previously. To do 
that you should deactivate TS phase. 

2.1 Criteria 

The criteria defines alternatives for the objectives of each calculation phase. In particular, the optimization criterion, applied 
to theoretic phase, expresses user intention with launch optimization. 

The rounding and completing criteria are offered to give users a chance to adjust calculation when the solution neither  
reach the expected optimum nor satisfy other desirable issues like a reduction in the number of patterns types. Both 
Rounding and Completing phases apply no exact but heuristic algorithms which means their optimum goals may not be 
fulfilled in all cases. 

We specially stop here to point out the completing alternative “Weight cost and yield up” which has a particular effect on 
variants finally chosen. It is implicitly selected when activated cost optimization, though could be also used in consumption 
optimization for which unitary cost in all materials is assumed, and prioritizes, at each step, variants with best cost/yield 
relation over those distributing parts in greater area. For this reason, it tends to generate more number of variants by using 
several materials.  

When material costs per unit of area are comparable each other, that is, the different between them is very small, 
optimization goal may be fulfilled best with criterion “Maximize completed area”, even though you wish optimize total cost 
and not consumption of launch. 

3. Actions 

 To customize calculation: 

Select “Options” from Tools menu and go into Calculation category. 

 To force next calculation process: 

Press Force button in calculation window. 

 To dynamically modify current process acceleration during calculation: 
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Use the slider on the left of Force button in calculation window. 
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Editing patterns manually 

You can adjust, modify or even create cutting patterns manually and force their usage in the solution of launch. 

In general, all editing actions on a pattern are realized by first selecting and then modifying a semi-product in its cuts 
hierarchy. (See cutting patterns) 

1. Adjustment 

Whenever allowed by pattern topology and not prevented by cutting technology, you can use the following options to modify 
cuts distribution without modifying parts repetition in a pattern. 

 Joint children 

Joints two children semi-products deleting this way the cut given.  

Two semi-products can join together if: 

a) Both are final and at least one is offcut. 

b) Both distribute the same part with equal repetition along cut direction. 

 Exchange children 

Exchanges two children semi-products modifying this way the cut location. 

 Extend cut 

In a cuts sequence of the same level (with equal direction), replaces the given cut with the next in sequence extending 
this way the cut distance.  

 Diminish cut 

Symmetrically to above option, reduces the cut distance. Also allows to delete the offcut in any part semi-product just 
preceding it.   

 Rotate cut 

Replaces the given cut with the cut in both children modifying this way the cut direction. 

A cut can be rotated if: 

a) Both children are cut in the rotated direction at the same distance. 

b) One of the children is cut as above and the other is an offcut. 

Next example realizes an adjustment sequence in a pattern to reduce the number of cuts. The goal is to joint semi-products 
distributing parts 2 and 3.   



Corte5 User’s Manual                     - 21 - 

 

Email: info@corteoptimo.com  

http://www.corteoptimo.comWeb:   

 

1.1 Automatic adjustment 

You can let program combine the above options (attempting) to reduce the number of cuts in a pattern. This automatic 
adjustment is applied by default when finalizing optimization. (Optimum variants are guaranteed with a minimum of cuts 
among all candidates. However, when limiting possible cuts chances for generating variant of simpler topology could be lost. 
See Calculation options) 

1.2 Offcut adjustment 

Independently you can adjust offcut automatically. This action will visit each part semi-product descending in cuts hierarchy 
and separate its inner offcut, in both directions, whether it fulfills Reusable Offcut configuration or  when its area is grater 
the area occupied by the parts. Offcut adjustment is always realized when finalizing optimization. 

2. Modification 

The following actions will allow you to modify cuts and parts distribution in a pattern manually: 

 Clean semi-product 

Turn a semi-product into an offcut by deleting all of its cuts and parts. 

 Define vertical or horizontal cuts 

You can cut only final semi-products: an offcut to split it into two halves (you can adjust cut distance later) and a 
part-semiproduct to separate inner offcut. 

 Modify cut distance 

You can modify cut distances without any restriction in spite of that could invalidate pattern topology since all children 
semi-products dimensions would be affected. It is allowed with the aim of facilitating manual deletion of inner offcuts.  

 Distribute parts 
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You can distribute parts only in final semi-products and define their rotation states and repetitions at both coordinates 
axes. Corte will suggest possible parts to distribute, among those with order not fulfilled yet, verifying they can fit 
into and indicating what percentage of semi-product area would be covered (pick list associated to Part ID property in 
Pattern Inspector).   

3. Creation and deletion 

At any time you can add or delete patterns in the solution. 

By default new patterns are created for the active material, in blank and with repetition 1. Then you can add cuts and 
distribute parts as explained before. 

4. Repetition  

You can modify a pattern repetition manually or let Corte calculates it automatically according to current parts order 
fulfillment. Note that repetition will be assigned in active rounding. 

5. Copying semi-products 

You can take advantage of an existing pattern topology to create a new pattern by copying and pasting semi-products. (See 
last actions below) 

6. Actions 

 To add patterns in the solution: 

1. From Material Sheet or Material Inspector, select the material to be used by the new pattern. 

2. From either Results or Patterns Sheet, select “Insert” or “Append” in Edit menu. 

 To delete patterns: 

1. Select a pattern in Patterns Sheet or several patterns in Results Sheet. 

2. Select “Delete” from Edit menu. 

 To adjust or modify cuts and part layouts: 

1. Select a semi-product in Patterns Sheet. 

2. Use modifying options from Adjust menu or change properties under “Current semi-product” category in Pattern 
Inspector. 

 To modify a pattern repetition: 

Select “Repetition” from Adjust menu or change it directly in Pattern Inspector. 

 To force usage of certain pattern in the solution: 

1. Delete patterns until being left just those you want to keep. 

2. Check all repetitions are as maximum as possible. 

3. Enable “Keep patterns” under Optimization category in Launch Inspector. 

4. Optimizes again. 

 To automatically adjust cuts or offcut in the selected semi-product: 

Select “Cuts” or “Offcut” from Adjust menu. 

⇒ To adjust the whole pattern, select its root node or none node at all. 

 To adjust cuts and offcut in all active patterns: 

Select equivalent options from Solution menu. 

 To deactivate automatic adjustment of patterns at the end of calculation: 

Select “Options” from Tools menu and uncheck “Adjust cuts…” in Output category. 

 To copy or move a semi-product: 

1. From a source pattern, select the semi-product to copy and remember its dimensions. 

2. Select “Copy” o “Cut” from Edit menu. 
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3. Activate a target pattern creating it new if necessary. 

4. Select a target semi-product (by creating it new if necessary) verifying their dimensions be equal or greater than the 
copied ones. 

5. Select “Paste” from Edit menu. 
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References and Labels 

References and labels are texts, respectively, identifying cutting objects in the different views of the launch and describing 
semi-products in the cutting patterns. You can customize all of these texts by defining output formats with parameters that 
updates themselves automatically according to the particular object they are referring to.  

1. References 

You can define Part, Material, Strip and Pattern reference formats using parameters for basic properties identifying all of 
these objects. Most parameters in patterns are applied to materials used by them; the rest are for Repetition, Cut Width and 
Margins properties. 

Examples of references are texts showed in the object selector of inspectors, part column titles in Results Sheet, pattern 
descriptions in reports, etc. 

2. Labels 

You can define Part, Cut and Offcut label formats using parameters for describing semi-products, cuts and parts, besides 
others for rotation state, edge-covering strips assignment, etc. (parameters in question are numerous and described in the 
interface so we don’t reproduce them here) 

2.1 Escape sequences 

Label formats are more flexible as for incorporating escape sequences controlling look, alignment or even the very 
generation of the label that can be conditioned according to current values of parameters. Corte notably facilitates label 
format definition including automatic generation of escape sequences. 

In the table below are all escape sequences you can use when defining a label format. 

 

SEQUENCE FUNCTION 

Alingmnet  

\vin Vertical alignment inside semi-product 

\vout Vertical alignment outside semi-product 

\vcut Vertical alignment aside the cut 

\hin \hout \hcut The same for horizontal alignment 

\top \bot \lef \rig \vcen 
\hcen 

Respectively, align to top, bottom, left, right border and vertical, horizontal center of 
semi-product 

Conditional  

\if<condición>\then 
 <format1> 
[\else 
<format2>] 
\endif 

If <condition> holds then apply <format1> else apply <format2> 
<condition is an expression of kind <operand>[<compare><operand>] where 
<operand> is either parameter or constant and <compare> is one of the 
comparison operators  = <> <= >=  <>  
If comparison is omitted then <condition> is false only if <operand>=0 

Font  

\font 
[<nombre>],[<tamaño>] 
 ,[bold],[italic] 
\endfont 

Defines the label font. The default sequence is \fontArial,8,bold\endfont  

Clipping  

\clipon \clipoff Enable or disable clipping of label text inside semi-product. 
The default is \clipon  

New line  

\n Force next text to appear in a new line 

(Brackets [] indicates content in could be omitted) 

2.1.1 Additional tips 

 Conditional sequences can be nested. 
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 Be careful when modifying alignment in formats defining it conditionally (as in Cut Label) since results could be 

self-defeating.  

 After resolving conditionals, the rest of sequences will be applied from left to right staying active the last one visited. In 
alignment case, any previously contradictory sequence will be deleted. 

 Clipping is applied only for labels aligned inside their semi-products. 

2.2 Definition levels 

Label formats can be defined at two levels: A general one as part of launch output configuration to generate default labels 
and a particular one to modify semi-product labels in place. Every semi-product has its own label format assigned implicitly 
with the sequence “\def” meaning “apply default format”. 

3. Actions  

 To modify launch’s Reference and Label formats: 

Select “Options” from Tools menu and modify “Output Formats” in Output category. 

 To modify a semi-product label: 

From the current semi-product in Patterns Sheet, select “Label” in Adjust menu. 
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How to 

Realize a cutting plan 

First you must decide whether one or several launches will be needed to carry out the plan by following a criterion of 
introducing into a single launch only those part and material formats that can be freely combined during optimization. When 
done, continue as follows: 

From File menu:  

1. Create a launch for the cutting task. 

From Prepare menu: 

2. Configure both measurement and consumption units. 

3. Configure the cutting technology. 

From Parts and Materials sheets: 

4. Enter formats for parts and materials. 

From File menu: 

5. Save the launch with a name descriptive of its function. 

From Solution menu: 

6. Calculate the cutting patterns. 

From Results and Patterns sheets, Reports menu and Launch inspector: 

7. Get the results. 

From File menu: 

8. Close the launch. 

 
Modify several data in a sole action 

You can modify several data at the same time by selecting a block of cells in the table view. Together with this action, all 
record (rows) containing them would also be selected. Then, you can type a value in the very table, modify a property in the 
associated inspector or apply other editing actions would affect all records selected. 

 To select a block of cells: 

a) Drag inside the table. 

b) Use arrow keys while keeping SHIFT pressed. 

 To quickly extend selection until table endings: 

Press End, Home, PgUp or PgDn with SHIFT down. The shortcuts CTRL+SHIFT+Home,End extends toward first and  
last cell, respectively. 

 To select rows or columns entirely: 

Click in row ID or column Title. You can repeat for another row or column while pressing SHIFT. 

 
Sort items in views 

You can sort items in table views  either automatically according to column values or manually by changing position of 
records. 

 To sort automatically: 

1. Activate a column to sort. 
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2. Select Sort | “Ascending” or “Descending” from Edit menu. 

 To sort manually: 

1. Select records to move. 

2. Select Sort | “Move up” o “Move down” from Edit menu. 

See Modify several data in a sole action. 

 
Import data from Excel 

You can import parts, materials and strips from Excel sheets. 

1. Activate the data sheet to import. 

2. Select Excel | “Import sheet” from File menu. 

From Excel Import window: 

3. Load an Excel book and activate the sheet from which data will be read. This actions can also be realized from the very 
Excel. To do that, press “Go to Excel” and from here on you can alternate Corte and Excel through Windows task 
bar. 

4. Defines a correspondence between fields in Corte and columns in Excel. If the first row in Excel contains field 
names, check the corresponding option in order to realize this assignment automatically. 

5. Once concluded import configuration, press Import.  

6. Select Close to finish importing and return to Corte. 

 
Define and assign edge-covering strips 

You can assign edge-coverings either before or after calculation. The strips consumption totals will be calculated from the 
parts real (not from order). 

1. Defines strips to use in the Strip Sheet. 

2. Select “Edge-coverings” from Prepare menu. 

3. On several steps, select parts having edge-coverings and assign strips in Part Inspector. 

 
Export data to Excel 

Select Excel | “Export book…” from File menu. 

You can export all program outputs to Excel spreadsheets including graphics of cutting patterns. This powerful tool will allow 
you integrating Corte with other applications as well as obtaining printings fully customized. 

Exported items are restricted to the same generation conditions applied to the rest of outputs. Graphics of patterns will use 
paper color configuration. 

 
Export AutoCad drawings 

Select AutoCAD | “Export DXF” from File menu. 

You can export all cutting pattern graphics to a single AutoCAD 2000 DXF drawing. The exported drawing will be 
automatically configured in order to facilitate edition and interpretation within AutoCAD environment: 

 Measurement units as defined for the launch in order to AutoCad dimensions reflect actual measures of patterns. 

 Label texts as viewed in Corte. 

 Filling entities for offcut areas. 

 Different layers for semi-product cuts, part cuts, offcuts and texts. 
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Condition geometry of patterns generated 

Modify the cutting technology. 

 
Reduce calculation time 

Select “Options” from Tools menu and check “Restrict possible cuts” in Calculation category. 

See also Calculation options. 

 
Customize output texts 

Select “Options” from Tools menu and modify Output Formats in Output category.   

You can customize formats for data references, pattern labels and cost, percentage, area, comsumption values. 

See also References and Labels. 

 
Customize the Results Sheet 

Select “Configure results” from View menu. 

 
Filter patterns in solution 

Select “Filter of patterns” from Solution menu. 

From Filter of Patterns window: 

 To filter just the patterns selected in Result Sheet: 

Press Selection. 

 To delete the current filter: 

Press Delete. 

 To filter according to values of some fields in Result Sheet: 

1. Check the fields you wish to filter by.  

2. Defines a filtering criterion for each field selected separating one from another with a semi-colon (;).  

A filtering criterion is a list of values or ranges separated by comma (,). A pattern will satisfy a criterion when its value 
in the corresponding field belongs to the specified list. Use a dash (-) to define ranges and an asterisk (*) as wildcard. 

Example: To filter patterns with a yield grater than 95.00 and repetitions 1, 3, 10, 11 and 12, use filtering criteria “95-
*;1,3,10-12”.  

3. Set the logic operation to combine criteria. 

Under AND a pattern will be filtered if all the criteria hold true. Under OR a pattern will be filtered if one of the criteria 
holds true no matter the rest. 

4. Press New to overwrite current filter or Modify to restrict current filter even more. 

 
Get partial results 

Restricts active patterns by applying a filter of patterns. 

See Filter patterns in solution. 
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Optimize cost instead of consumption 

Do the following actions: 

1. From Material Inspector, assign costs per unit of area (Cost/uA) to all materials. 

2. From Launch Inspector, select “Minimize cost” under Optimization category. 

3. Optimize the launch. 

 
Create and modify patterns manually 

See Editing patterns manually. 

 
Optimize groups of formats separately 

Realize calculation of the solution at several stages guaranteeing for each: 

1. Activate just parts and materials formats you want to optimize. 

In patterns calculation only active formats are included. Parts with order fulfilled are automatically discarded hence you 
may omit deactivating them. 

3. Keep within solution all patterns calculated at previous stages. 

By default, the current solution is always cleaned before launching a new calculation. You should enable 
“Keep patterns”, under Optimization category in Launch Inspector, to modify this behavior. 

4. Modify any “relaxed” parameter in cutting technology. 

Except for mixing bars and sheets cutting or changing the Cut Width, you may adjust technology of each group before 
launching optimization again. 

When documenting a launch optimized this way, you might need get partial results for each group of patterns generated. 

See also the example launch “13 Parts into two optimization groups” supplied with installation. The Technician’s notes 
(Tools | Options) explain steps realized. 

 
Optimize profiles cutting at angle 

You can optimize  cutting at angle of symmetric profiles by configuring a special case of bars cutting as follows: 

1. For each profile, define a part of Lengh equal to its straight part without including both extremes beveled at angle. 

2. Defines the Cut Width as the length of the angular cut measured horizontally along the profile. 

3. Defines Left and Right margins, both the same as Cut Width, in order to first and last profiles in a pattern can be cut. 

 

 
Optimize multiple parts punching in CNC presses 

Punching presses CNC programs defines complex-shaped parts punching patterns using a set of standard punches. 
Generally, they also include code to extract multiple parts of the same type by repeating incrementally its punching pattern 
over a grid of coordinated points.  

You can use Corte to optimize the layout of these “groups” of multiple parts guaranteeing CNC presses manufacturing 
restrictions and minimizing material consumption. Do that as follows: 

1. For each part to punch, calculate the smallest rectangle containing its punching pattern and define the corresponding 
part in Corte.  



How to                       - 30 - 

Email: info@corteoptimo.com  

Web: http://www.corteoptimo.com   
2. Define a Cut Width to guarantee material strength. 

3. Defines any necessary margin mainly the bottom one for the holding-dead zone of the press.  

4. Defines the Maximum Cut with the repositioning distance of the press to guarantee all parts in the same group can be 
extracted without repositioning. 

5. If CNC allows to easily obtain programs for parts rotated 90 degrees, activate Rotate Parts to increase chances for 
optimizing. If not, disable this option.  

6. Introduce all material available with their original dimensions. 

 

After optimizing, final part semi-products will correspond to multiple punching groups. CNC coding parameters like relative 
coordinates origin, part to distribute and repetitions along X and Y axes can be read in Cutting Parameters report and also in 
Pattern Inspector. 
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